Back to overview
Degraded

Elevated declined payments

Aug 15 at 07:36am BST
Affected services
Checkout

Resolved
Aug 15 at 02:25pm BST

Decline rates are at normal levels for the last several hours. We continue to monitor the system closely. If you notice any false positives, please reach out to our customer support and we will investigate as a priority.

We apologise for the issues caused by this morning's episode. Acceptance rates are one of the most important aspects of Tebex, and our team are ensuring this doesn't happen again.

Updated
Aug 15 at 11:10am BST

The elevated decline rates are now stabilising and we're returning to normal.

Our team continues to closely monitor potential false positives.

We would like to apologise for the issues caused in the last few hours.

Updated
Aug 15 at 09:12am BST

We have identified the cause of the elevated declines and we are resolving the issue. We will continue to provide updates as we know more.

Created
Aug 15 at 07:36am BST

We are aware of an issue with elevated levels of declined payments occurring. This is caused by an incorrect configuration of one of our risk engines. We are working on resolving this and will update everyone as soon as possible.