Back to overview
Degraded

Authentication error logging in with Steam

Feb 12 at 02:01am GMT
Affected services
Webstores

Resolved
Feb 12 at 10:06am GMT

Steam's OpenID authentication/login system is back online and functioning again.

Created
Feb 12 at 02:01am GMT

We are aware of an ongoing issue affecting webstores that require customers to authenticate via Steam, resulting in a "Whoops, looks like something went wrong." error upon logging in.

Our findings suggest that this originates from Steam and is impacting other platforms also utilising Login With Steam.

We are closely monitoring the situation and actively reaching out to Steam for a resolution.