Back to overview
Degraded

Payment Decline Errors

Oct 20 at 08:42am BST
Affected services
Checkout

Resolved
Oct 20 at 01:10pm BST

All payment processing is now fully operational, and transactions are being completed as expected.

Updated
Oct 20 at 11:52am BST

As AWS services continue to recover, payment processing is beginning to return to normal. We are closely monitoring the situation and will mark the incident as resolved once we’ve confirmed that all systems are fully operational.

Updated
Oct 20 at 08:49am BST

The ongoing issues seem to be linked to the current AWS incident affecting multiple services across the internet. We’re actively working to minimise the impact and are hopeful that AWS services will be restored soon.

Created
Oct 20 at 08:42am BST

We have observed elevated payment declines and are currently investigating. Our team are working on this and will update once we have identified the issue.