Back to overview
Degraded

Elevated declined payments

Nov 22 at 12:15am GMT
Affected services
Checkout

Resolved
Nov 22 at 05:25pm GMT

We have implemented a number of adjustments on our side to help minimise the impact of the issue for affected customers. These measures are intended to provide some stability and reduce disruption while the downstream provider continues working to identify and fix the root cause. We will keep monitoring the situation closely and make further improvements where possible.

Created
Nov 22 at 12:15am GMT

We are aware of an increase in declined payments affecting some customers due to a downstream issue with one of our card acquirers. The issue has been escalated to the relevant third party, and we are working closely with them to resolve it. We will provide further updates as soon as more information becomes available.