Back to overview
Degraded

Global Cloudflare Outage

Dec 05 at 09:04am GMT
Affected services
Homepage
Creator Panel
Webstores
Accounts
Wallet
Checkout
Game Server Plugins
Affiliates
Webhooks

Resolved
Dec 05 at 09:23am GMT

The service disruption caused by the Cloudflare outage has now been resolved.

Webstores and all affected areas of the Tebex platform are fully operational again. Our systems are running normally, and traffic has resumed without errors.

Created
Dec 05 at 09:04am GMT

We’re currently experiencing service disruptions caused by an outage affecting our upstream provider, Cloudflare.

https://www.cloudflarestatus.com/

As a result, some users may encounter 500 Server Errors when accessing webstores or certain areas of the Tebex platform. Our internal systems are functioning normally, but because the majority of our traffic flows through Cloudflare, we are affected by their incident.

We are actively monitoring Cloudflare’s status and will provide updates as soon as the issue is resolved.

Thank you for your patience and understanding.