Back to overview
Downtime

Increased Error Rates

Feb 26 at 03:38pm GMT
Affected services
Creator Panel
Webstores
Accounts
Wallet
Checkout
Game Server Plugins
Affiliates
Webhooks

Resolved
Feb 26 at 03:41pm GMT

We have successfully stabilised the affected database server and error rates have returned to normal levels. While service is fully restored, our team is continuing a deep-dive investigation into the underlying cause of the load spike to ensure long-term stability.

Created
Feb 26 at 03:38pm GMT

At 15:38 UTC, one of our core database clusters experienced an unexpected load spike, resulting in slow response times and intermittent errors for some users. Our engineering team is currently investigating the root cause and implementing measures to prevent a recurrence..